如何安装“ mpich”库? [关闭] -- 16.04 领域 和 compiling 领域 askubuntu 相关 的问题

How can I install `mpich` library? [closed]


7
vote

问题

中文

如何安装 mpich 库?我尝试编译WRF ,但无法安装。

英文原文

How can I install mpich library? I tried compiling WRF but I could not install it.

     
     
     

回答列表

6
 
vote

转到 http://www.mpich.org/downloads/ 并单击<用于Ubuntu 16.04的code> Xenial 。这将带您到这里: https://packages.ubuntu.com/xenial/mpich 。然后单击 amd64 ,您在这里: https:// packages.ubuntu.com/xenial/amd64/mp​​ich/download 。上面写着:

如果您正在运行Ubuntu,强烈建议使用一个软件包 经理,例如aptitude或synaptic来下载和安装软件包, 而不是通过此网站手动进行操作。

因此,不要手动安装,请使用:

  $ sudo apt install mpich Reading package lists... Done Building dependency tree        Reading state information... Done The following additional packages will be installed:   cpp-5 g++-5 gcc-5 gcc-5-base gfortran gfortran-5 hwloc-nox libasan2 libatomic1   libcc1-0 libcilkrts5 libcr-dev libcr0 libgcc-5-dev libgfortran-5-dev libgfortran3   libgomp1 libhwloc-plugins libhwloc5 libitm1 liblsan0 libmpich-dev libmpich12 libmpx0   libquadmath0 libstdc++-5-dev libstdc++6 libtsan0 libubsan0 Suggested packages:   gcc-5-locales g++-5-multilib gcc-5-doc libstdc++6-5-dbg gcc-5-multilib libgcc1-dbg   libgomp1-dbg libitm1-dbg libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg   libubsan0-dbg libcilkrts5-dbg libmpx0-dbg libquadmath0-dbg gfortran-multilib   gfortran-doc gfortran-5-multilib gfortran-5-doc libgfortran3-dbg blcr-dkms   libhwloc-contrib-plugins libstdc++-5-doc blcr-util mpich-doc The following NEW packages will be installed:   gfortran gfortran-5 hwloc-nox libcr-dev libcr0 libgfortran-5-dev libhwloc-plugins   libhwloc5 libmpich-dev libmpich12 mpich The following packages will be upgraded:   cpp-5 g++-5 gcc-5 gcc-5-base libasan2 libatomic1 libcc1-0 libcilkrts5 libgcc-5-dev   libgfortran3 libgomp1 libitm1 liblsan0 libmpx0 libquadmath0 libstdc++-5-dev libstdc++6   libtsan0 libubsan0 19 upgraded, 11 newly installed, 0 to remove and 213 not upgraded. Need to get 41.0 MB of archives. After this operation, 39.0 MB of additional disk space will be used. Do you want to continue? [Y/n]    

此时,单击 y 安装该软件包。

无需像您尝试的那样从源代码进行编译。

 

Go to http://www.mpich.org/downloads/ and click on Xenial for Ubuntu 16.04. This takes you here: https://packages.ubuntu.com/xenial/mpich. Then click on amd64 and you are here: https://packages.ubuntu.com/xenial/amd64/mpich/download. Where it says:

If you are running Ubuntu, it is strongly suggested to use a package manager like aptitude or synaptic to download and install packages, instead of doing so manually via this website.

So instead of installing manually, use:

$ sudo apt install mpich Reading package lists... Done Building dependency tree        Reading state information... Done The following additional packages will be installed:   cpp-5 g++-5 gcc-5 gcc-5-base gfortran gfortran-5 hwloc-nox libasan2 libatomic1   libcc1-0 libcilkrts5 libcr-dev libcr0 libgcc-5-dev libgfortran-5-dev libgfortran3   libgomp1 libhwloc-plugins libhwloc5 libitm1 liblsan0 libmpich-dev libmpich12 libmpx0   libquadmath0 libstdc++-5-dev libstdc++6 libtsan0 libubsan0 Suggested packages:   gcc-5-locales g++-5-multilib gcc-5-doc libstdc++6-5-dbg gcc-5-multilib libgcc1-dbg   libgomp1-dbg libitm1-dbg libatomic1-dbg libasan2-dbg liblsan0-dbg libtsan0-dbg   libubsan0-dbg libcilkrts5-dbg libmpx0-dbg libquadmath0-dbg gfortran-multilib   gfortran-doc gfortran-5-multilib gfortran-5-doc libgfortran3-dbg blcr-dkms   libhwloc-contrib-plugins libstdc++-5-doc blcr-util mpich-doc The following NEW packages will be installed:   gfortran gfortran-5 hwloc-nox libcr-dev libcr0 libgfortran-5-dev libhwloc-plugins   libhwloc5 libmpich-dev libmpich12 mpich The following packages will be upgraded:   cpp-5 g++-5 gcc-5 gcc-5-base libasan2 libatomic1 libcc1-0 libcilkrts5 libgcc-5-dev   libgfortran3 libgomp1 libitm1 liblsan0 libmpx0 libquadmath0 libstdc++-5-dev libstdc++6   libtsan0 libubsan0 19 upgraded, 11 newly installed, 0 to remove and 213 not upgraded. Need to get 41.0 MB of archives. After this operation, 39.0 MB of additional disk space will be used. Do you want to continue? [Y/n]  

At this point click y to install the package.

There is no need to compile from source like you were attempting to do.

 
 

相关问题

1  VMware-Ubuntu 16.04自动注销  ( Vmware ubuntu 16 04 automatically log out ) 
我使用VMware运行Ubuntu 每隔一小时,我的ubuntu会自动注销 我已经更改了设置并且还更改了"超时" ,但是无效 以下文本是我的日志文件 有人遇到过这个问题吗? 请帮我 谢谢 Feb 28 15:17:01 yangningfan-virtual-machine CRON[82277]: (root)...

2  Ubuntu 16.04到18.04升级在libhin1挂起  ( Ubuntu 16 04 to 18 04 upgrade hangs at libhin1 ) 
我正在将服务器从Ubuntu 16.04疯狂升级到18.04。此时,某些升级进展顺利,而某些服务器则挂起 : Preparing to unpack .../libnih1_1.0.3-6ubuntu2_amd64.deb ... Unpacking libnih1:amd64 (1.0.3-6ubuntu2)...

2  使用Deadsnakes ppa作为我的主要python3实例,使python3引用python3,7会有什么问题? [关闭]  ( What problems can i expect using deadsnakes ppa as my primary python3 instance t ) 
已关闭。这个问题是基于观点的。它当前不接受答案。 <路径d =" M15 6.38A6.48 6.48 0 007.78。 04h-.02A6.49 6.49 0 002.05 5.6a6.31 ...

0  rEFind-已安装,配置为主引导,但不引导,仅grub  ( Refind installed configured as primary boot but does not boot only grub ) 
我有Ubuntu 16.04 LTS,我安装了grub和rEFind。 我以前正常使用rEFind,但几天前他停了工作。 我设置为主引导顺序,但是在引导时仅显示grub。 检查: dcbasso@DanteNB:~$ sudo efibootmgr -v BootCurrent: 0000 Timeout: 0...

0  使用Ubuntu软件无法安装.deb应用程序[复制]  ( Unable to install deb applications with ubuntu software ) 
这个问题已经在这里有答案: 无法从软件中心获取Atom文本编辑器 (2个答案) ...

4  海豚属性下的文件类型选项不起作用。 Ubuntu 16.04  ( File type options under properties on dolphin does not work ubuntu 16 04 ) 
我已经在Ubuntu 16.04上安装了海豚,除了Nautilus以外。当我选择一个文件并转到属性,然后按文件类型选项按钮时,没有任何反应。应该会出现一个窗口,显示可能的应用程序,但是什么也没有发生。 我正在使用东芝PortégéZ30-C-138。 有什么想法吗? 谢谢 哈维尔 ...

0  Ubuntu 16.04和Cubic用于自定义内核  ( Ubuntu 16 04 and cubic for customised kernel ) 
以前有一个类似的问题,但其中没有有效的解决方案。 背景-我正在尝试在具有H740p PERC或RAID卡的Dell服务器上安装Ubuntu 16.04服务器。 问题-安装过程中安装程序无法检测到硬盘。 根据此帖子,16.04无法识别此RAID卡及其建议使用16.4.4 HWE内核,而在另一篇文章中,有人使用内核v4....

3  16.04更新后无声音,已通过内核回滚恢复  ( No sound after update of 16 04 restored with kernel rollback ) 
已关闭。这个问题是离题。它当前不接受答案。 <路径d =" M15 6.38A6.48 6.48 0 007.78。 04h-.02A6.49 6.49 0 002.05 5.6a6.31 6.3...

0  加载Ubuntu时出现黑屏  ( Black screen when loading ubuntu ) 
几天前,我发布了有关此问题的信息,不仅我没有解决问题,而且尝试解决问题变得更糟。 新问题是由更新内核引起的,正如我看到有人在其他地方建议的那样。安装进行得很顺利,除了一些警告,我的集成GPU可能缺少一些驱动程序(我认为这是这里的主要问题)。但是,现在Ubuntu已加载,但屏幕上看不到任何内容。我也尝试做 Ctrl ...

1  如何在我的Ubuntu 16.04台式机上使用蓝牙耳机?  ( How do i get a bluetooth headset working with my ubuntu 16 04 desktop ) 
我有一个蓝牙耳机。我已经在(Android)手机上使用了它,但是我想使其与运行Ubuntu 16.04的桌面一起使用。我插入了USB蓝牙加密狗, lsusb 看到: $ lsusb | grep Blue Bus 005 Device 010: ID 0a5c:21e8 Broadcom Corp. BCM207...

7  播放/暂停无法正常工作  ( Play pause not working spotify ) 
我在2013年的macbook pro上运行了通过macOS Mojave双重引导的Ubuntu 16.04。直到大约一周前,播放/暂停/跳过键与Spotify完美配合。现在他们根本没有响应。我最近在Mac方面更新为Mojave,但我不知道这是问题所在。重新启动没有帮助。欢迎任何建议! ...

0  已解决-尽管GRUB正常且分区未销毁,W10更新阻止了Lubuntu引导  ( Solved w10 update prevents lubuntu from booting although grub is ok and partit ) 
我最近购买了配备Intel Core i7-7700和8Gb RAM的DELL Vostro 3268台式机。 这是一个 UEFI系统。 它随附了预装在1Tb HDD(= sda)上的W10。 我希望我的系统更快,并购买了240Gb SSD(= sdb)。 我需要使用Lubuntu作为主要系统,但还需要保留W10(我...

3  Ubuntu 16.04:Compiz使用太多的CPU  ( Ubuntu 16 04 compiz uses way too much cpu ) 
此问题已在此处提供答案: Compiz连续使用8%-25%CPU (4个答案) ...

0  更新/ etc / crontab以在工作时间内每隔一分钟以root身份退出进程  ( Update etc crontab to quit a process as root every other minute during working ) 
如何在工作时间内每隔一分钟更新/ etc / crontab以root用户身份退出进程,因为在这种情况下,周一至周六为0800-1600。我如何还允许同一进程在12.00-12.30和16:00-07:59之间处于活动状态? sudo nano /etc/crontab ...

1  除非禁用安全启动,否则Ubuntu 16.04无法连接到WiFi  ( Ubuntu 16 04 cant connect to wifi unless secure boot is disabled ) 
我最近安装了Ubuntu 16.04,但是除非禁用安全启动,否则我无法连接到WiFi。有没有更好的解决方案,还是必须禁用安全启动? ...




© 2021 it.wenda123.org All Rights Reserved. 问答之家 版权所有