Numpy不能与虚幻引擎存在于同一系统上-能力? -- 16.04 领域 和 dependencies 领域 和 aptitude 领域 和 clang 领域 askubuntu 相关 的问题

Numpy can't exist on the same system as Unreal Engine - aptitude?


简体版||繁體版
1
vote

问题

中文

我在解决Ubuntu 16.04 LTS上的Unreal Engine依赖项时遇到了极其困难的时间。现在,我遇到了一个难题,这似乎要求我删除numpy或放弃我的Unreal Engine安装。有人可以解释一下我将同时使用这两种方法时可能如何解决此问题。这是我为clang-3.8安装依赖项(称为libblang1-3.8)时从aptitude记录的日志。 简而言之,clang-3.8及其依赖项是一个问题

  The following NEW packages will be installed:   libclang1-3.8 libobjc-5-dev{ab} libobjc4{ab}  0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded. Need to get 4,624 kB of archives. After unpacking 18.4 MB will be used. The following packages have unmet dependencies:  libobjc4 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed.  libobjc-5-dev : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed.                  Depends: libgcc-5-dev (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed. The following actions will resolve these dependencies:       Keep the following packages at their current version: 1)     libclang1-3.8 [Not Installed]                       2)     libobjc-5-dev [Not Installed]                       3)     libobjc4 [Not Installed]                               Accept this solution? [Y/n/q/?] n The following actions will resolve these dependencies:        Remove the following packages:                                               1)      libgfortran3                                                               2)      liblapack3                                                                 3)      python-numpy                                                                      Downgrade the following packages:                                            4)      cpp-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           5)      g++-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           6)      gcc-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           7)      gcc-5-base [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      8)      gcc-5-base:i386 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 9)      libasan2 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        10)     libatomic1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      11)     libcc1-0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        12)     libcilkrts5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]     13)     libgcc-5-dev [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]    14)     libgomp1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        15)     libitm1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]         16)     liblsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        17)     libmpx0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]         18)     libquadmath0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]    19)     libstdc++-5-dev [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 20)     libstdc++6 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      21)     libstdc++6:i386 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 22)     libtsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        23)     libubsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]              Leave the following dependencies unresolved:                                 24)     inkscape recommends python-numpy                                             Accept this solution? [Y/n/q/?] q Abandoning all efforts to resolve these dependencies. Abort.   
英文原文

I'm having an exceedingly difficult time resolving dependencies for Unreal Engine on Ubuntu 16.04 LTS. I'm now being presented with a dilemia which appears to require me to either remove numpy or give up my installation for Unreal Engine. Can someone please explain how I can potentially resolve this issue as I will be using both. Here is the log from aptitude when I'm installing a dependency for clang-3.8 known as libblang1-3.8. In short, clang-3.8 and its dependencies are the issue:

The following NEW packages will be installed:   libclang1-3.8 libobjc-5-dev{ab} libobjc4{ab}  0 packages upgraded, 3 newly installed, 0 to remove and 0 not upgraded. Need to get 4,624 kB of archives. After unpacking 18.4 MB will be used. The following packages have unmet dependencies:  libobjc4 : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed.  libobjc-5-dev : Depends: gcc-5-base (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed.                  Depends: libgcc-5-dev (= 5.3.1-14ubuntu2) but 5.4.0-6ubuntu1~16.04.6 is installed. The following actions will resolve these dependencies:       Keep the following packages at their current version: 1)     libclang1-3.8 [Not Installed]                       2)     libobjc-5-dev [Not Installed]                       3)     libobjc4 [Not Installed]                               Accept this solution? [Y/n/q/?] n The following actions will resolve these dependencies:        Remove the following packages:                                               1)      libgfortran3                                                               2)      liblapack3                                                                 3)      python-numpy                                                                      Downgrade the following packages:                                            4)      cpp-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           5)      g++-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           6)      gcc-5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]           7)      gcc-5-base [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      8)      gcc-5-base:i386 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 9)      libasan2 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        10)     libatomic1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      11)     libcc1-0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        12)     libcilkrts5 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]     13)     libgcc-5-dev [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]    14)     libgomp1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        15)     libitm1 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]         16)     liblsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        17)     libmpx0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]         18)     libquadmath0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]    19)     libstdc++-5-dev [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 20)     libstdc++6 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]      21)     libstdc++6:i386 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)] 22)     libtsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]        23)     libubsan0 [5.4.0-6ubuntu1~16.04.6 (now) -> 5.3.1-14ubuntu2 (xenial)]              Leave the following dependencies unresolved:                                 24)     inkscape recommends python-numpy                                             Accept this solution? [Y/n/q/?] q Abandoning all efforts to resolve these dependencies. Abort. 
           

回答列表


相关问题

32  如何安装gcc-7或clang 4.0?  ( How to install gcc 7 or clang 4 0 ) 
我想尝试C ++ 17功能,并且想安装符合标准的编译器(最好是GCC)。我对Linux和Ubuntu完全陌生,只是我不太了解。 我试图遵循 https://launchpad.net/~ubuntu -toolchain-r / + archive / ubuntu / test ,但是没有运气。首先我跑了: s...

12  将clang-3.8设置为默认值  ( Set clang 3 8 as default ) 
我已经安装了clang 3.0和clang 3.8: $ sudo update-alternatives --config clang update-alternatives:错误:没有替代的clang。 如何将3.8设置为 /usr/bin/clang ? ...

2  clang-3.7缺少Asan错误的解决方法  ( Workaround for clang 3 7 missing asan bug ) 
有一个已知错误与Debian有关libclang软件包似乎是用自动工具编译的,但是只有库的cmake构建才能生成用于消毒程序的库。 该错误会影响libclang-common-3.7。导致链接错误,例如 /usr/bin/ld.gold: error: cannot open /usr/lib/llvm-3.7/...

0  找不到clang-3.2的候选版本。无法执行某些操作,正在中止  ( No candidate version found for clang 3 2 unable to apply some actions aborting ) 
您好,我正在尝试安装clang 3.2版。我想要这个版本,因为我想要一些在新版本中不存在的外部选项(dumping-objects-memory-layout)。 我的问题是我无法安装旧版本。例如,当我尝试安装时 sudo apt-get install clang-3.2 我收到此消息: Read...

8  如何使用预编译的二进制文件安装CLang?  ( How to install clang using precompiled binaries ) 
如何使用我下载的CLang的预编译二进制文件在Ubuntu上安装CLang? 这是我下载CLang的方式:" LLVM下载页面" -> "下载LLVM 3.2" -> " Ubuntu-12.04 / x86_64的Clang二进制文件" ( http://llvm.org/releases/3.2/cl...

1  在Ubuntu 12.04上安装clang 3.3并查看未满足的依赖项错误  ( Install clang 3 3 on ubuntu 12 04 and see unmet dependencies errors ) 
ubuntu@ubuntu-VirtualBox:~/Downloads$ sudo apt-get install clang-3.3 clang-3.3-doc libclang-common-dev libclang-dev libclang1 libclang1-dbg libllvm-3.3-ocaml...

2  在Ubuntu上安装Atom遇到gvfs-bin错误  ( Installing atom on ubuntu encounters errors with gvfs bin ) 
因此,我正在尝试在运行Xubuntu 14.04(64位)的Chromebook上安装Atom。我从atom.io下载了.deb,但是当我运行 sudo dpkg -i atom-amd64.deb 时,它返回了: Selecting previously unselected package atom. ...

0  使用c构建的内核和c构建的VMware内核模块的VMware Player(14.1.1)段错误  ( Vmware player14 1 1 segfaults on clang built kernel and clang built vmware ker ) 
作为使用不同的用clang构建的内核版本进行的clang / LLVM实验和探索的一部分,我尝试在Ubuntu 17.10 x86_64上使用用clang构建的VMware内核模块( vmmon < / code>和 vmnet )安装在用lang创建的主机内核4.16(到目前为止最新稳定)上。 问题 当我使用 VM...

5  libasan包之间的差异(libasan0,libasan2,libasan3等)  ( Difference between libasan packes libasan0 libasan2 libasan3 etc ) 
libasan有很多类似的命名包(gcc和clang的地址清理器): $ apt-cache search libasan | grep -v dbg | grep -v cross libasan2 - AddressSanitizer -- a fast memory error detector liba...

3  系统升级后Clang ++找不到lstdc ++  ( Clang cannot find lstdc after system upgrade ) 
我有一个C ++小项目,在将Xubuntu升级到15.04之前,它的编译效果很好。当我尝试使用cmake重建它时,此消息出现在输出的中间: /usr/bin/ld: cannot find -lstdc++ 因此,我尝试编写一个简单的程序来查看 cmake 是否对此负责: int main() { ...

5  安装Clang ++时未满足的依赖性  ( Unmet dependencies when installing clang ) 
此问题已在此处提供答案: 如何安装clang ++? (3个答案) 已关闭...

4  未定义的引用编译14.04.2上的clang教程  ( Undefined references compiling clang tutorial on 14 04 2 ) 
我试图从 clang的libtooling教程编译代码("将它们放在一起" )。编译作品: g++ `llvm-config-3.5 --cxxflags` -fno-rtti -c test.cpp -o test.o 我从clang获得了未定义的引用,所以我什至尝试链接所有clang库: CLAN...

6  我如何知道已安装的Clang版本?  ( How i know what version of clang i have installed ) 
我如何知道已安装的clang版本? ...

0  使用clang编译较早的ubuntu版本  ( Build with clang for older ubuntu releases ) 
因此,当我最近更新Ubuntu Vivid(15.04)时,问题开始了。现在 clang-3.5 依赖于 libstdc++-4.9 (而不是先前版本的 4.8 ),并且我的编译程序无法在Trusty(14.04)上运行: ./my_app: /usr/lib/x86_64-linux-gnu/libstdc++...

16  在ubuntu上安装llvm和clang  ( Llvm and clang installation on ubuntu ) 
因此,我正在尝试在Ubuntu 12.04(64位)上安装 Halide 。我需要安装llvm-3.2和clang。 正在运行 sudo apt-get install llvm-3.2 的结果是"未找到软件包" 。 尝试 sudo apt-get install llvm 或 sudo apt-get insta...

-1  有clang 3.4。,需要clang 2.9  ( Have clang 3 4 need clang 2 9 ) 
我在ubuntu 14.04中安装了clang和llvm的默认版本,它的版本是3.4。很好,但是对于某些旧版内容,我需要2.9版。 理想情况下,我可以同时安装两个版本,并将它们与" clang-3.4 test.c" 和" clang-2.9 test.c" 一起使用,同时选择默认情况下"平原test.c" 所指的版...

1  安装最新版本的libc ++  ( Install latest version of libc ) 
虽然我知道,但是我可以从 http://apt.llvm安装最新的xenial clang编译器.org / xenial / (Doku: https://apt.llvm.org/ )我无法确定如何安装最新版本的libc ++(llvm的标准库实现)。 是否有单独的存储库,还是必须手动下载并编译该库的最新版本?...

3  升级到gcc-4.9打破了clang ++  ( Upgrade to gcc 4 9 broke clang ) 
最近我已经升级到gcc-4.9,但是它完全破坏了我的clang ++,我无法编译任何东西。我收到错误消息: In file included from src/tester.cpp:11: In file included from /usr/include/boost/progress.hpp:22: In f...

0  即使安装了clang3.8也无法使用clang编译.cpp文件  ( Cant compile cpp file with clang even after installing clang3 8 ) 
在使用以下命令重新安装Ubuntu 15.10之后,我安装了clang3.8和其他通常需要使用的其他软件包: $ sudo apt-get install clang-3.8 clang-3.8-doc libclang-common-3.8-dev libclang-3.8-dev libclang1-3.8 ...

2  我需要哪个软件包将clang与asan一起使用32位?  ( Which package do i need to use clang with asan for 32 bit ) 
使用 clang++ 和 -fsanitize=address -m32 编译时出现此错误: /usr/bin/ld: cannot find /usr/lib/llvm-3.6/bin/../lib/clang/3.6.0/lib/linux/libclang_rt.asan-i386.a: No such f...

0  试图从源代码编译铬浏览器,但未找到“地图”文件而失败  ( Trying to compile chromium browser from source but failing with map file not ) 
我已经下载了铬浏览器的源代码。 另外: keepassxc6 我已经安装了库(以及更多): keepassxc7 失败: keepassxc8 这只是一个标准库文件,出了什么问题? 完整版本输出: https://paste.ubuntu.com/p/54v5CwW3qD/ clang ...

0  无法在ubuntu上安装pyside2  ( Unable to install pyside2 on ubuntu ) 
我已经使用克隆了pyside2回购 $ git clone --recursive https://codereview.qt-project.org/pyside/pyside-setup 并使用 https://askubuntu.com/a/799998/653786 安装了llvm3.9 但是当我运...

5  错误的默认包含目录用于clang交叉编译吗?  ( Wrong default include directories for clang cross compile ) 
我的构建机器是xenial x86_64。我正在交叉编译arm-linux-gnueabihf。我已经安装了g ++-arm-linux-gnueabihf。 使用 clang++ --target=arm-linux-gnueabihf 进行构建时,出现错误" /usr/bin/../lib/gcc-cross/...

32  如何安装LLVM 3.9  ( How to install llvm 3 9 ) 
我正在使用Emscripten,错误消息之一是: LLVM version appears incorrect (seeing "3.3", expected "3.9") 但是在LLVM页面上找不到3.9: http://llvm.org/releases/download.html#3.8.0 如...

0  无法安装Clang和LLVM-没有uint64_t定义  ( Trouble installing clang and llvm no uint64 t definition ) 
我运行了 ./configure ,但是当我尝试 make llvm 时,出现以下错误: [ 0%] Building CXX object lib/Support/CMakeFiles/LLVMSupport.dir/APFloat.cpp.o In file included from /opt/sta...




© 2021 it.wenda123.org All Rights Reserved. 问答之家 版权所有